Exception: Mongo::Error::SnapshotSessionInvalidServerVersion

Inherits:
Mongo::Error
  • Object
show all
Defined in:
build/ruby-driver-master/lib/mongo/error/snapshot_session_invalid_server_version.rb

Overview

Exception raised if an operation using a snapshot session is directed to a pre-5.0 server.

Since:

  • 2.0.0

Constant Summary

Constants inherited from Mongo::Error

BAD_VALUE, CODE, CURSOR_NOT_FOUND, ERR, ERRMSG, ERROR, TRANSIENT_TRANSACTION_ERROR_LABEL, UNKNOWN_ERROR, UNKNOWN_TRANSACTION_COMMIT_RESULT_LABEL, WRITE_CONCERN_ERROR, WRITE_CONCERN_ERRORS, WRITE_ERRORS

Instance Attribute Summary

Attributes included from Notable

#generation, #service_id

Instance Method Summary collapse

Methods inherited from Mongo::Error

#add_label, #change_stream_resumable?, #label?, #labels, #write_concern_error_label?, #write_concern_error_labels

Methods included from Notable

#add_note, #notes, #to_s

Constructor Details

#initializeSnapshotSessionInvalidServerVersion

Instantiate the new exception.

Since:

  • 2.0.0



26
27
28
# File 'build/ruby-driver-master/lib/mongo/error/snapshot_session_invalid_server_version.rb', line 26

def initialize
  super("Snapshot reads require MongoDB 5.0 or later")
end