Navigation

Upgrade a Standalone to 4.0

Important

MongoDB 4.0 may lose data during unclean shutdowns on macOS 10.13+.

For details, see WT-4018.

The following steps outline the procedure to upgrade a standalone mongod from version 3.6 to 4.0.

Important

Before you attempt any upgrade, please familiarize yourself with the content of this document.

If you need guidance on upgrading to 4.0, MongoDB offers major version upgrade services to help ensure a smooth transition without interruption to your MongoDB application.

Upgrade Recommendations and Checklists

When upgrading, consider the following:

Upgrade Version Path

To upgrade an existing MongoDB deployment to 4.0, you must be running a 3.6-series release.

To upgrade from a version earlier than the 3.6-series, you must successively upgrade major releases until you have upgraded to 3.6-series. For example, if you are running a 3.4-series, you must upgrade first to upgrade first to 3.6 before you can upgrade to 4.0.

Preparedness

Before beginning your upgrade, see the Compatibility Changes in MongoDB 4.0 document to ensure that your applications and deployments are compatible with MongoDB 4.0. Resolve the incompatibilities in your deployment before starting the upgrade.

Before upgrading MongoDB, always test your application in a staging environment before deploying the upgrade to your production environment.

Downgrade Consideration

Once upgraded to 4.0, if you need to downgrade, we recommend downgrading to the latest patch release of 3.6.

Prerequisites

Remove Support for MONGODB-CR

Starting in version 4.0, MongoDB removes support for the deprecated MongoDB Challenge-Response (MONGODB-CR) authentication mechanism.

If your deployment has user credentials stored in MONGODB-CR schema, you must upgrade to Salted Challenge Response Authentication Mechanism (SCRAM) before you upgrade to version 4.0. For information on upgrading to SCRAM, see Upgrade to SCRAM.

Remove Support for $isolated

MongoDB drops support for the $isolated operator. If you have an existing partial index that includes the $isolated operator or a view that includes a $isolated operator, recreate the index or view without the operator in the definition before upgrading.

Feature Compatibility Version

The 3.6 instance must have featureCompatibilityVersion set to 3.6. To check featureCompatibilityVersion:

db.adminCommand( { getParameter: 1, featureCompatibilityVersion: 1 } )

The operation should return a result that includes "featureCompatibilityVersion" : { "version" : "3.6" }.

To set or update featureCompatibilityVersion, run the following command:

db.adminCommand( { setFeatureCompatibilityVersion: "3.6" } )

For more information, see setFeatureCompatibilityVersion.

Download 4.0 Binaries

Via Package Manager

If you installed MongoDB from the MongoDB apt, yum, dnf, or zypper repositories, you should upgrade to 4.0 using your package manager.

Follow the appropriate installation instructions for your Linux system. This will involve adding a repository for the new release, then performing the actual upgrade process.

Manually

If you have not installed MongoDB using a package manager, you can manually download the MongoDB binaries from the MongoDB Download Center.

See Install MongoDB for more information.

Upgrade Process

1

Replace existing 3.6 binaries with the 4.0 binaries.

Shut down your mongod instance. Replace the existing binary with the 4.0 mongod binary.

Restart your deployment with the 4.0 mongod.

2

Enable backwards-incompatible 4.0 features.

At this point, you can run the 4.0 binaries without the 4.0 features that are incompatible with 3.6.

To enable these 4.0 features, set the feature compatibility version (FCV) to 4.0.

Tip

Enabling these backwards-incompatible features can complicate the downgrade process since you must remove any persisted backwards-incompatible features before you downgrade.

It is recommended that after upgrading, you allow your deployment to run without enabling these features for a burn-in period to ensure the likelihood of downgrade is minimal. When you are confident that the likelihood of downgrade is minimal, enable these features.

Run the setFeatureCompatibilityVersion command against the admin database:

db.adminCommand( { setFeatureCompatibilityVersion: "4.0" } )

This command must perform writes to an internal system collection. If for any reason the command does not complete successfully, you can safely retry the command as the operation is idempotent.

Additional Upgrade Procedures