Docs Menu

Release Notes for MongoDB 2.4

On this page

  • Minor Releases
  • Major New Features
  • Security Enhancements
  • Performance Improvements
  • Enterprise
  • Additional Information

March 19, 2013

MongoDB 2.4 includes enhanced geospatial support, switch to V8 JavaScript engine, security enhancements, and text search (beta) and hashed index.

  • Partially written journal last section causes recovery to fail SERVER-15111.
  • Explicitly zero .ns files on creation SERVER-15369.
  • 2.4.12 Changelog.
  • All 2.4.12 improvements.

The following changes in MongoDB affect both standard and Enterprise editions:

Add support for text search of content in MongoDB databases as a beta feature. See Text Indexes for more information.

Add new hashed index to index documents using hashes of field values. When used to index a shard key, the hashed index ensures an evenly distributed shard key. See also Hashed Sharding.

  • Improve support for geospatial queries. See the $geoWithin operator and the $geoNear pipeline stage.
  • Improve sort efficiency when the $sort stage immediately precedes a $limit in the pipeline.
  • Add new operators $millisecond and $concat and modify how $min operator processes null values.

The mapReduce command, group command, and the $where operator expressions cannot access certain global functions or properties, such as db, that are available in the mongo shell. See the individual command or operator for details.

Provide additional metrics and customization for the serverStatus command. See db.serverStatus() and serverStatus for more information.

  • Introduce a role-based access control system User Privileges now use a new format for Privilege Documents.
  • Enforce uniqueness of the user in user privilege documents per database. Previous versions of MongoDB did not enforce this requirement, and existing databases may have duplicates.
  • Support encrypted connections using SSL certificates signed by a Certificate Authority. See Configure mongod and mongos for TLS/SSL.

For more information on security and risk management strategies, see MongoDB Security Practices and Procedures.

Change default JavaScript engine from SpiderMonkey to V8. The change provides improved concurrency for JavaScript operations, modernized JavaScript implementation, and the removal of non-standard SpiderMonkey features, and affects all JavaScript behavior including the commands mapReduce, group, and eval and the query operator $where.

See JavaScript Changes in MongoDB 2.4 for more information about all changes .

Enable basic BSON object validation for mongod and mongorestore when writing to MongoDB data files. See wireObjectCheck for details.

Provide --setParameter as a command line option for mongos and mongod. See mongod and mongos for list of available options for setParameter.

By default, each document move during chunk migration in a sharded cluster propagates to at least one secondary before the balancer proceeds with its next operation. See Chunk Migration and Replication.

Increase performance for moving multiple chunks off an overloaded shard. The balancer no longer waits for the current migration's delete phase to complete before starting the next chunk migration. See Asynchronous Chunk Migration Cleanup for details.

The following changes are specific to MongoDB Enterprise Editions:

In 2.4.4, MongoDB Enterprise uses Cyrus SASL. Earlier 2.4 Enterprise versions use GNU SASL (libgsasl). To upgrade to 2.4.4 MongoDB Enterprise or greater, you must install all package dependencies related to this change, including the appropriate Cyrus SASL GSSAPI library. See Install MongoDB Enterprise for details of the dependencies.

In 2.4, the MongoDB Enterprise now supports authentication via a Kerberos mechanism. See Configure MongoDB with Kerberos Authentication on Linux for more information. For drivers that provide support for Kerberos authentication to MongoDB, refer to Driver Support.

For more information on security and risk management strategies, see MongoDB Security Practices and Procedures.

For macOS, MongoDB 2.4 only supports macOS versions 10.6 (Snow Leopard) and later. There are no other platform support changes in MongoDB 2.4. See the downloads page for more information on platform support.

See Upgrade MongoDB to 2.4 for full upgrade instructions.

Give Feedback
© 2021 MongoDB, Inc.

About

  • Careers
  • Legal Notices
  • Privacy Notices
  • Security Information
  • Trust Center
© 2021 MongoDB, Inc.