Navigation

MongoDB Enterprise Kubernetes Operator Compatibility

Kubernetes and OpenShift Versions

The Kubernetes Operator is compatible with the following Kubernetes and OpenShift versions. Unless otherwise noted, each Kubernetes Operator version listed spans the full release series starting from the listed version.

Versions in italics are deprecated.

Kubernetes Operator Release Series Kubernetes Version OpenShift Version
1.0.0 1.11, 1.12, 1.13, 1.14 3.11, 4.0, 4.1
1.1.0 1.11, 1.12, 1.13, 1.14 3.11, 4.0, 4.1
1.2.0 1.13, 1.14, 1.15 3.11, 4.0, 4.1
1.3.0 1.14, 1.15, 1.16 3.11, 4.0, 4.1
1.4.0 1.14, 1.15, 1.16 3.11, 4.0, 4.1, 4.2 [1], 4.3 [1]
1.5.0 1.14, 1.15, 1.16, 1.17, 1.18 3.11, 4.0, 4.1, 4.2, 4.3, 4.4
1.6.0 1.16, 1.17, 1.18, 1.19 3.11, 4.2, 4.3, 4.4, 4.5
[1](1, 2) Kubernetes Operator v1.4.3 and later

MongoDB Versions

The Kubernetes Operator is compatible with the following MongoDB versions. Unless otherwise noted, each Kubernetes Operator version listed spans the full release series starting from the listed version.

Kubernetes Operator Release Series MongoDB Version
1.0.0 3.6, 4.0
1.1.0 3.6, 4.0, 4.2
1.2.0 3.6, 4.0, 4.2
1.3.0 3.6, 4.0, 4.2
1.4.0 3.6, 4.0, 4.2
1.5.0 3.6, 4.0, 4.2
1.6.0 4.0, 4.2, 4.4 [2]
[2]Kubernetes Operator v1.6.1 and later

Cloud Manager and Ops Manager Versions

The Kubernetes Operator is compatible with Cloud Manager and with the following Ops Manager versions. Unless otherwise noted, each Kubernetes Operator version listed spans the full release series starting from the listed version.

Kubernetes Operator Release Series Ops Manager Version
1.0.0 4.0, 4.2
1.1.0 4.0, 4.2
1.2.0 4.0, 4.2
1.3.0 4.0, 4.2
1.4.0 4.0, 4.2
1.5.0 4.0, 4.2
1.6.0 4.0, 4.2, 4.4