Navigation

    Compatibility

    The Kafka Sink Connector requires MongoDB 3.6 or later; it is unsupported for older versions of MongoDB.

    The Kafka Source Connector requires MongoDB 3.6 or later as your data source if you are using change streams with a collection only. If you need to watch a database or deployment, you need MongoDB 4.0 or later.

    Info With Circle IconCreated with Sketch.Note

    The MongoDB Connector for Apache Kafka is only tested against MongoDB clusters. If you use the MongoDB Kafka connector with a non-genuine MongoDB database, it may not function correctly due to differences in features or feature behavior.

    The MongoDB Connector for Apache Kafka requires Apache Kafka Connect API version 2.1.0 or later and is tested against Apache Kafka 2.3 and above. There are many Kafka compatible platforms that work with the Kafka Connect service such as:

    • Confluent Platform 5.3 or later
    • Microsoft Azure Event Hubs
    • Red Hat AMQ Streams

    The MongoDB Connector works directly with Kafka Connect; it does not make direct connections to the Kafka cluster on the backend. Therefore, the MongoDB Connector should work with any Apache Kafka platform that supports Kafka Connect including those listed above. If you have any questions about the connector, feel free to ask on the MongoDB Community Forums.

    Give Feedback