Docs Menu

Compatibility

The Kafka Sink Connector requires MongoDB 3.6 or later.

The Kafka Source Connector requires MongoDB 3.6 or later.

If you are using MongoDB 3.6, the connector can only listen for changes on collections. If you need the connector to listen for changes on a database or deployment, you must use MongoDB 4.0 or later.

Note

We recommend that you only use the MongoDB Kafka Connector with an official version of the MongoDB server. We cannot guarantee it functions correctly with any other version.

The MongoDB Kafka Connector requires Kafka Connect version 2.1.0 or later. It's tested against Apache Kafka 2.3 and later. You can use the Kafka Connect service with several Apache Kafka compatible platforms including the following:

  • Confluent Platform 5.3 or later
  • Microsoft Azure Event Hubs
  • Red Hat AMQ Streams

The MongoDB Kafka Connector works directly with Kafka Connect. The connector does not connect directly to a Kafka cluster which means it's compatible with any Apache Kafka platform that supports Kafka Connect.

If you have any questions about the MongoDB Kafka Connector, feel free to ask them on the MongoDB Community Forums.

Give Feedback
MongoDB logo
© 2021 MongoDB, Inc.

About

  • Careers
  • Legal Notices
  • Privacy Notices
  • Security Information
  • Trust Center
© 2021 MongoDB, Inc.