Navigation

    Compatibility

    MongoDB Compatibility

    Node.js DriverMongoDB 4.4MongoDB 4.2MongoDB 4.0MongoDB 3.6MongoDB 3.4MongoDB 3.2MongoDB 3.0MongoDB 2.6
    >= 3.6
    >= 3.5
    >= 3.4
    >= 3.3
    >= 3.2.1
    >= 3.1
    >= 3.0
    >=2.2.12
    >=2.0.14
    >=1.4.29

    Language Compatibility

    Node.js DriverNode.js v0.8.XNode.js v0.10.XNode.js v0.12.XNode.js v4.X.XNode.js v6.X.XNode.js v8.X.XNode.js v10.x.xNode.js v12.x.xNode.js v14.x.x
    3.6.X
    3.5.X
    3.4.X
    3.3.X
    3.2.X
    3.1.X
    3.0.X
    2.2.X
    2.1.X
    2.0.X
    >=1.4.18
    1.4.X